SchoolAdmin supports the current versions of the following browsers:

  • Chrome desktop and mobile
  • Safari desktop and mobile
  • Firefox
  • Microsoft Edge

Testing and support are provided for the current point version only.

Older browsers are deemed insecure by payment processing vendors due to requirements for TLS1.2+ support and lack of security updates.

Parent or admin users trying to access the site on unsupported or out-of-date browsers will receive a message about this and will need to switch to using one of the browsers listed above in order to proceed.

Did this answer your question?